Author Topic: ASP Mac bug: Lag with color editor open  (Read 1098 times)

postdes

  • Jr. Member
  • **
  • Posts: 72
ASP Mac bug: Lag with color editor open
on: March 18, 2019, 05:35:35 AM
I noticed that in the last version of ASP on the Mac, I get a lot of lag (rotating beachball) when I have the color editor window opened.

Normally I would paint, then quickly switch to the eraser and back again. When I open up the color editor window this slows down a lot, and each time I switch tools it takes a few seconds before I can use the tool. This happens every time I switch tools, with all tools where the color editor is visible. When I close the color editor, everything is smooth again.

Perhaps there is some memory bleed or other bug. I hope you can resolve it. Thanks!

Lucky Clan

  • Administrator
  • Hero Member
  • *****
  • Posts: 1462
    • Lucky Clan homepage
Re: ASP Mac bug: Lag with color editor open
Reply #1 on: March 18, 2019, 05:55:10 AM
It happens probably when you are using color palette with large number of swatches. It will be improved in version 2.2.

postdes

  • Jr. Member
  • **
  • Posts: 72
Re: ASP Mac bug: Lag with color editor open
Reply #2 on: March 18, 2019, 06:51:58 AM
I tried switching to the basic palette with fewer color, though it might be slightly better, it is still much worse than it was before. In fact it never used to be a problem, so something must have changed, or some kind of bug crept in. I checked the activity monitor, and it seems that ASP almost used the double amount of CPU when I have the color editor open. This seems abnormal to me.

I hope a quicker fix can be made than to wait for the next big update, which might take months.

Lucky Clan

  • Administrator
  • Hero Member
  • *****
  • Posts: 1462
    • Lucky Clan homepage
Re: ASP Mac bug: Lag with color editor open
Reply #3 on: March 18, 2019, 10:50:12 AM
I will try to find a workaround.