Author Topic: Version 598 serious bug  (Read 2076 times)

lastaccess

  • Full Member
  • ***
  • Posts: 190
Version 598 serious bug
on: February 07, 2021, 04:17:30 AM
After each moving/zooming canvas brush loses 99.9% of flow (it is automatically set to 0.1%), so you should set it back. App is unusable atm.

Update:
It is not only 2 fingers. 3 or 4 also drops flow to 0.1%
Last Edit: February 07, 2021, 04:20:09 AM by lastaccess

Kardas

  • Newbie
  • *
  • Posts: 22
Re: Version 598 serious bug
Reply #1 on: February 07, 2021, 04:54:09 AM
Can confirm, after update to 598 putting more than one finger on the canvas (not the palm) sets flow to 0%. Disabling gestures and enabling pen only mode doesn’t do anything, so it may be unrelated.

Temporary Fix I found until it gets patched is going back to the documents view in the app, and closing it. Then the bug disappears until you restart the app.
Last Edit: February 07, 2021, 05:16:03 AM by Kardas

SONB

  • Newbie
  • *
  • Posts: 1
Re: Version 598 serious bug
Reply #2 on: February 07, 2021, 05:19:39 AM
Confirm the bug.
Unfortunately can't confirm the workaround.

Kardas

  • Newbie
  • *
  • Posts: 22
Re: Version 598 serious bug
Reply #3 on: February 07, 2021, 05:24:29 AM
Confirm the bug.
Unfortunately can't confirm the workaround.

Odd, I can’t reproduce the workaround anymore as well but managed to reproduce it 2 times before in that manner.

Edit 2: actually managed to temporary fix the issue again 6+ more times, but seems inconsistent what gets rid of it, at one point going back from one app back to art studio fixed it, on another 2 occasions opening the preferences menu and closing it fixed it. On another few occasions opening a bunch of apps and going back to AsP fixed it, if not open a bunch of more apps and go back. On another opening apps and using my 1 finger gestures to adjust brush size/flow fixed it. Seemingly clicking around and random events can get rid of it, once it’s gone it’s gone until you open a new document.

Edit3: ..and apparently it’s not a fix, instead of the bug auto setting it to 0% it auto sets now to 100% flow instead, I guess that’s better than nothing.
Last Edit: February 07, 2021, 06:18:33 AM by Kardas

Kardas

  • Newbie
  • *
  • Posts: 22
Re: Version 598 serious bug
Reply #4 on: February 07, 2021, 06:09:18 AM
Ok found the fastest, easiest and 100% so far working way to get it to set to 100% instead of 0%. At least on my device(iPad Pro 12inch 2018)

Open art studio pro and a document, if you haven’t it set already, set 1 finger function in gestures to “adjust brush size/opacity”, go back to the document, drag your finger all the way UP (adjust brush size), and that’s it, the bug switches from 0% to 100%. If you open a new document, you have to do that again.  Hope it helps until it’s fixed.
Last Edit: February 07, 2021, 06:17:57 AM by Kardas

Vesrian

  • Newbie
  • *
  • Posts: 4
Re: Version 598 serious bug
Reply #5 on: February 07, 2021, 01:45:07 PM
Ok it's a bit of a relief Im not the only one experiencing this, it's SUCH a frustrating bug haha, I hope they fix it asap D:

Lucky Clan

  • Administrator
  • Hero Member
  • *****
  • Posts: 1986
    • Lucky Clan homepage
Re: Version 598 serious bug
Reply #6 on: February 07, 2021, 01:58:59 PM
Please disable finger size/opacity function until new version is released.  We will fix it in 1-2 days.

barel

  • Newbie
  • *
  • Posts: 24
Re: Version 598 serious bug
Reply #7 on: February 07, 2021, 03:02:09 PM
To be clear, disabling finger size/opacity doesn’t change anything for me, eyedropper and none, finger only mode all do the same thing. At one point it no longer dropped flow on the brush tool, but continued to do so on wet brush and smudge tools.
Disabling all gestures individually also solved nothing.
Also worth noting that only flow is affected, even when prefer opacity slider is selected and the gesture controls opacity, not flow.
I have also had zooming repeatedly set flow to 91% on all three tools, but don’t know what caused it.

AdanMGarcia

  • Newbie
  • *
  • Posts: 2
Re: Version 598 serious bug
Reply #8 on: February 07, 2021, 03:58:28 PM
Please fix soon. App is unusable with this bug. 🙁

Lucky Clan

  • Administrator
  • Hero Member
  • *****
  • Posts: 1986
    • Lucky Clan homepage
Re: Version 598 serious bug
Reply #9 on: February 07, 2021, 04:39:26 PM
Working on a fix now, i will submit new version asap.

Lucky Clan

  • Administrator
  • Hero Member
  • *****
  • Posts: 1986
    • Lucky Clan homepage
Re: Version 598 serious bug
Reply #10 on: February 07, 2021, 05:16:18 PM
Fixed version 3.0.17 is waiting for review, it should be available in few hours.

maika57

  • Newbie
  • *
  • Posts: 2
Re: Version 598 serious bug
Reply #11 on: February 07, 2021, 09:52:57 PM
Same issue here, also noticing some brushes aren’t working, even after the slider is manually reset to 100%.  Even when I increase the size of the brush and draw on the screen nothing is happening. Not with all, but have noticed it on several.

Lucky Clan

  • Administrator
  • Hero Member
  • *****
  • Posts: 1986
    • Lucky Clan homepage
Re: Version 598 serious bug
Reply #12 on: February 08, 2021, 03:54:25 AM
Which brushes are not working?

Same issue here, also noticing some brushes aren’t working, even after the slider is manually reset to 100%.  Even when I increase the size of the brush and draw on the screen nothing is happening. Not with all, but have noticed it on several.

Lostar

  • Newbie
  • *
  • Posts: 14
Re: Version 598 serious bug
Reply #13 on: February 08, 2021, 05:59:59 AM
Both brushes I use; digital round brush and Borodante brush is affected by this paralyzing glitch.


Lucky Clan

  • Administrator
  • Hero Member
  • *****
  • Posts: 1986
    • Lucky Clan homepage
Re: Version 598 serious bug
Reply #14 on: February 08, 2021, 06:26:19 AM
Yes, it is probably the sam bug. I hope Apple will accept the fix is very soon.

Both brushes I use; digital round brush and Borodante brush is affected by this paralyzing glitch.