Author Topic: Deleting and rearranging color swatches are not consistent. Apple Pencil or not?  (Read 556 times)

Dorothyfan1

  • Full Member
  • ***
  • Posts: 166
There seems to be an inconsistent issue using the Apple Pencil and my fingers in ASP when trying to delete or rearrange color swatches.. When selecting color swatches for either deletion or rearranging I get this inconsistent popup to delete or rearrange them when using either the Apple Pencil or my fingers. It’s a case of “ASP loves me. ASP loves me not” issue. Sometimes you hit the color swatch with the Apple Pencil or your finger and you get the popup saying you can delete or rearrange the groups. But then when I go back to the same color swatch by clicking on the group icon the message doesn’t appear anymore. What’s with that behavior? Then I go to another color swatch and I get the message again. I go to another one and the message doesn’t appear. What’s going on here? I’m sorry but I think this is an issue that needs fixing.

Edit: I want to be clear on this. This is NOT an iPad issue at all. I’m able to select any of the other panels in ASP and I don’t get this inconsistent behavior anywhere else. I can tap any of the other panels and everything responds quickly as I’d expect them to. I’m not getting any inconsistent behavior when using the Apple Pencil when using it to select any of the toolbars or using brushes on artwork. I’m getting this issue only with the color swatch popups for rearranging groups and deleting.

Edit: I think this issue has been addressed? Apparently one has to “select” the color swatch to see the orange highlight on the group name before choosing the swatch to get the option to rename, rearrange and delete? I’m still watching this one. There might still be an issue with this here.
Last Edit: April 12, 2021, 08:17:58 AM by Dorothyfan1

Lucky Clan

  • Administrator
  • Hero Member
  • *****
  • Posts: 2222
    • Lucky Clan homepage
I cannot reproduce the issue. Long press on color swatch is always working on my iPad.

Dorothyfan1

  • Full Member
  • ***
  • Posts: 166
I cannot reproduce the issue. Long press on color swatch is always working on my iPad.

Does the color swatch need to have focus get the option to rearrange and delete? Because I tried this on a color swatch that didn't have any focus and I didn't get the popup menu option.