Lucky Clan Forum

Support => Suggestions, Ideas, Bugs => Topic started by: gregg2g on February 27, 2019, 09:40:55 AM

Title: Huion support
Post by: gregg2g on February 27, 2019, 09:40:55 AM
I don't know if you support Huion Tablets. But I have been having problems with ArtStudio Pro working correctly. It is the only program that does this.
It's hard to explain. ASP locks up so I can't select layers. While using the brush, I tap the pencil to the tablet and lines are drawn....almost like a vector program drawing straight lines. And finally, all of a sudden ASP will go into a busy mode....not responding.
I am using a Huion GT-156HD V2 with version 14.3.10.181225 software on Mac OS Mojave v 10.14.3.
Title: Re: Huion support
Post by: Lucky Clan on February 27, 2019, 10:11:25 AM
I was testing that on my Huion H640P and everything worked fine, but it was a year ago.
I will test it again asap, maybe Apple changed something in Mojave, or drivers were somehow modified so it freezes Artstudio.
Title: Re: Huion support
Post by: gregg2g on February 27, 2019, 12:46:44 PM
Thank you. I would like to hear your results.
Title: Re: Huion support
Post by: gregg2g on March 05, 2019, 08:56:36 AM
Have you tested your Huion yet? I thought with the update to v2.1 that it would maybe fix the problems, but that didn't happen. So Artstudio Pro for the Mac OS is not usable for me right now.
Title: Re: Huion support
Post by: Lucky Clan on March 05, 2019, 02:51:58 PM
Not yet, sorry. I will do it this week.
Title: Re: Huion support
Post by: gregg2g on March 06, 2019, 09:22:27 AM
Thanks again.
Title: Re: Huion support
Post by: Lucky Clan on March 07, 2019, 08:04:57 AM
I reproduced and fixed the bug. Please wait for the next minor update, and make sure you have the most recent Huion driver installed.
Title: Re: Huion support
Post by: gregg2g on March 07, 2019, 08:31:34 AM
Thank you so much for everything.
Title: Re: Huion support
Post by: Lucky Clan on March 12, 2019, 06:43:37 AM
gregg2g - could you confirm Huion is working fine now?
Title: Re: Huion support
Post by: gregg2g on March 12, 2019, 08:38:51 AM
Yes, it has been working great for me the last couple of days.
I only problem I have is with the scrollbar on my Huion. It does not work very smooth. As I try to zoom in by scrolling on the Huion, it zooms in by very large jumps. Otherwise, everything seems to be working just great.
But that problem is no big deal. I get around pretty well on the Mac OS side of ASP.
Thank you for your support.
Title: Re: Huion support
Post by: gregg2g on March 26, 2019, 06:53:06 PM
Just update my Mac to Mojave 10.14.4 and my project does not open on my Huion correctly.
After you fix it the last time ASP worked well for a short time and then would freeze. This kept on happening. I would have to close ASP and start again.
Title: Re: Huion support
Post by: Lucky Clan on March 27, 2019, 10:34:31 AM
Please give me more details, i mean how to repeat the problem.
It is working fine on my iMac with Mojave 10.4.4 and Huion H640P
Title: Re: Huion support
Post by: gregg2g on March 27, 2019, 12:57:24 PM
I've attached a picture of my desktop. You can see, my 20inX16in 300dpi is only partially in view. I can pan the drawing inside of this small area.
Title: Re: Huion support
Post by: Lucky Clan on March 27, 2019, 05:00:45 PM
Please Assign Color Profile to None, and let me know if the problem still exists.
Title: Re: Huion support
Post by: gregg2g on March 27, 2019, 06:24:20 PM
I look at "Color Profile" under the Image menu and it only had "Assign" and "Match." Of which I know nothing about. (Stil would be nice to have help manual)
Anyway, this time I restarted my computer without the Huion app and monitor turned on. Then I open ArtStudio Pro and opened the Photoshop document. Everything looks good as it should.
I started the Huion app and still, everything looks good. Turned on the Hunion tablet monitor and the problem returns in ASP.
Puzzling, because ASP is the only software that I have this problem with.

Ok, update. I looked under the Image>Color Profile>Assign and it was set to "None."
Title: Re: Huion support
Post by: Lucky Clan on March 28, 2019, 04:55:27 AM
Ok, it seems i have to buy one to check this... Huion with screen is totally diffrenent from cheap Huion tablet.
Title: Re: Huion support
Post by: gregg2g on March 28, 2019, 08:36:35 AM
I know you have a few ASP users who use Huion and XP-Pen tablets. Thank you for your support. I believe Huion and XP-Pen tablet monitors will be just as good as Wacom in the not too future. And that is at a more affordable price.
Title: Re: Huion support
Post by: Lucky Clan on April 01, 2019, 03:44:53 AM
Please tell me which Mac computer are you using (Macbook, iMac, Mac Mini etc) ?
Title: Re: Huion support
Post by: gregg2g on April 01, 2019, 08:27:19 AM
27" Late 2015 iMac.
Title: Re: Huion support
Post by: Lucky Clan on April 01, 2019, 09:27:53 AM
I have exactly the same iMac!
One more question - what cable did you use to connect Huion to iMac?
Title: Re: Huion support
Post by: gregg2g on April 01, 2019, 10:18:24 AM
I had to buy an "HDMI to Mini USB 4K" adapter cable.
Another thing. I will be upgrading my Huion from GT-156HD V2 (15.6 in) to the new and larger Kamvas Pro 20 GT-192 today....if my Amazon order comes in as expected.
Waiting to see if I have the same problem.
Title: Re: Huion support
Post by: Lucky Clan on April 01, 2019, 10:26:43 AM
Could you send me link to this cable (on amazon or apple store)?
Title: Re: Huion support
Post by: gregg2g on April 01, 2019, 12:32:26 PM
Amazonhttps://www.amazon.com/Cirago-Mini-DisplayPort-HDMI-Adapter/dp/B016R1GGL2/ref=sr_1_fkmrnull_1?keywords=cirago+dpn2032w4k&qid=1554136205&s=gateway&sr=8-1-fkmrnull
I have a Cirago DPN2032W4k HDMI to mini display port 4k adapter cable.

Sorry for the miss-information earlier. For some reason, I was thinking of a mini USB port. I bought mine at Fry's Electronics: close to my house.
Title: Re: Huion support
Post by: Lucky Clan on April 01, 2019, 04:50:10 PM
Thanks for your help, i will try to fix it this week
Title: Re: Huion support
Post by: gregg2g on April 01, 2019, 06:13:50 PM
Thanks for all the help!
Title: Re: Huion support
Post by: gregg2g on April 02, 2019, 12:35:04 PM
There is a little tip I have been using on my Wacom tablet and Huion Tablet Monitors. I paint white dots on my express keys with Acrylic paint. That way, when it is dark in the room and I am getting the bright light from the monitor, I can see the express keys.
Title: Re: Huion support
Post by: Lucky Clan on April 02, 2019, 05:05:40 PM
Please give me more details. What does it mean ‘I paint white dots on my express keys’?
Title: Re: Huion support
Post by: gregg2g on April 02, 2019, 06:12:13 PM
You have what Huion called Press Keys or express keys on the side of the Tablet or Tablet Monitor. For example, I would set one of my keys to a keyboard shortcut B for using the brush and another for G for the bucket tool, etc.
They are on the top side of the tablet window and are programmable for shortcut keys.
Because the tablets are usually black, and the buttons are also black. In a dark room (early morning for example), it is hard to see the buttons.
So I painted a white dot on each button.
Title: Re: Huion support
Post by: Lucky Clan on April 03, 2019, 06:42:53 AM
I partly reproduced the problem. It happens only when I drag Artstudio Pro window from iMac screen to Huion screen, do you confirm?
Title: Re: Huion support
Post by: gregg2g on April 03, 2019, 08:49:02 AM
I don't understand the dragging of Artstudio Pro from the iMac screen to Huion screen.
I just got my new Huion Kamvas Pro 20 and everything so far seems to work except zoom bar (button/express key) on the top of tablet next to the screen.
I get around that by using the "command +" and "command -" keys I have programmed into the express keys.
So, I don't know what is going on between my older Huion and new Huion.
Title: Re: Huion support
Post by: Lucky Clan on April 04, 2019, 02:46:29 AM
Version 2.1.9 is available now! Please test if your Huion Kamvas is working fine now.
Title: Re: Huion support
Post by: gregg2g on April 04, 2019, 12:40:07 PM
Haven't received an update yet from the App Store. When I do, I will let you know. 
Title: Re: Huion support
Post by: Lucky Clan on April 04, 2019, 01:52:30 PM
Just go to Updates in App Store apps, and refresh the list.
Or find Artstudio Pro and tap Update.
Title: Re: Huion support
Post by: gregg2g on April 04, 2019, 03:45:53 PM
Ok, I installed Version 2.1.9 after following your directions and reloading the update page in the App Store.
So far, everything seems to work fine. I will give this version a try on a drawing I've been working on (I saved in Artstudio format).
My scroll bar on the top of my tablet still only scrolls out (-) and not in (+). I have to use the command+ and command- keys for that.
Title: Re: Huion support
Post by: Lucky Clan on April 05, 2019, 03:42:24 AM
I reproduced and fixed problem with Zoom In - i had to change shortcut from Cmd= to Cmd+. New update will be available soon
Title: Re: Huion support
Post by: gregg2g on April 05, 2019, 08:48:38 AM
Thank you for that fix. I have been having problems (freezes) with the drawing/painting I am working on. Maybe it is because of the size of the file. In Artstudio format it is 93 MB. The problems happen in the layer panel when I deleted a layer and selected other layers.
Anyway, I will try again some today.
Thanks again for all of the help you are giving.
Title: Re: Huion support
Post by: gregg2g on April 05, 2019, 04:51:01 PM
First, I tried opening File>Recent>my drawing and I got the same problem of a small square with my drawing in it (as before).
Then I just went to open and opened the Artstudio file that way. I worked on my drawing and everything seemed to be going good and then the layers started acting up. Some would disappear and then re-appear. This went on for a couple of minutes and I got to a place where I could save the drawing and exit/quit Artstudio Pro.
Scary. I thought I had lost parts of my drawing. The layer area has something going on that is causing layers to appear, disappear and looks like, move into Group layer. When the Group layer would be selected, the layers would all appear again.
Title: Re: Huion support
Post by: gregg2g on April 07, 2019, 10:18:50 AM
File>Open Recent seems to be a problem every time I try to use it. (Same as above) Plus, cannot close the picture from the picture icon (X) on the top Left of UI. Had to quit ASP and reopen picture using the File>Open.
For some reason, the opacity on the Bucket Fills changes back to 30% from 100% every so often.
I remove the "Group Layers" and the layers panel seem to work ok. I then added the "Group Layer" from ASP. I wanted to see if there may have been a difference and it appears to be. It may have been a problem with other program Folders instead of Group command.
Title: Re: Huion support
Post by: Lucky Clan on April 08, 2019, 06:38:36 AM
I cannot reproduce problems you described. If possible please record that on video.
I suppose it may happen after pressing some buttons on Huion tablet.
Title: Re: Huion support
Post by: gregg2g on April 08, 2019, 10:21:26 AM
As luck has it, I just finished the painting. See "Show Your Work>Old Logs and Eagle" in this forum.
As I work on new projects/paintings, I will let you know how things go.
Thanks again for all of your help and work.
Title: Re: Huion support
Post by: gregg2g on April 11, 2019, 12:54:39 PM
Thanks for the new update that fixes the Huion Zoom. Everything seems to be working better except I had a freeze up again because of the Layer panel. I add a layer and then tried a bucket fill (layer was above the Reference Layer), I tried to undo and move the layer under the Reference Layer (for better results). Everything froze. I could still quit ASP from the menu.
Title: Re: Huion support
Post by: Lucky Clan on April 11, 2019, 01:30:00 PM
Can you repeat that every time?
If yes, please record that using a smartphone and send me a video.
Title: Re: Huion support
Post by: gregg2g on April 11, 2019, 01:48:38 PM
I tried repeating and everything worked great. I worked in electronics in the Navy and we would every once in a while have an intermittent problem in our electronics gear. The hardest thing in the world to troubleshoot. So I can imagine this is one of those problems.
I'll just keep plugin along and see what happens and keep a log of any other instances of this problem.

Oh, and thanks for the Reference Layer. I love it!