Lucky Clan Forum

Support => Suggestions, Ideas, Bugs => Topic started by: postdes on February 10, 2019, 11:16:46 AM

Title: Issues in last beta
Post by: postdes on February 10, 2019, 11:16:46 AM
Thanks for the new beta!

Unfortunatly, i can not get the multitouch features to work as described. I tried pen only mode, and pen and finger mode: in pen only mode nothing happens when i put a finger on the canvas. In pen and finger mode, the shape or line freezes when putting a finger on the canvas, but without snapping to an angle or ratio.

In the transform tool, gestures only move the canvas, but not the selection. Basically nothing happens, in neither drawing mode.  :-\

The new expand function does not seem to work. Whenever i set a pixel value other than zero, the fill tool does not do anything.

I like the color bar in drawing mode, the switch is quite ingenious and works well. What i find confusing in the drawing mode is the position of the brush and color editor. It would make more sense to me, when the brush editor window would pop up when clicking on the tool icon at the top. The color icon could perhaps be at the top of of the bar at the left (size and opacity) above the switcher and permanently visible. This would clean up the UI. The switch between pen only or pen/finger mode could be in preferences, as i don‘t believe you would switch between these modes frequently. What i miss is the „...more“ menu from the normal UI, which i use mostly for switching drawing mode or brush blend mode.

I have some more UI ideas, but i will post these in another thread.
Title: Re: Issues in last beta
Post by: postdes on February 10, 2019, 04:10:16 PM
Some things i found out now: in the transform tool, you have to select multitouch in mode, this was not clear to me. It works now, as it should, although i prefer the non-multitouch version for precision.

As for snapping: i got it to work on selections, when using the rectangle and. Ircle mode, which is good.

As for using it with the brush tools: i got it to work once or twice when using the pen/finger mode, but most of the time it just freezes the line. It is hit and miss really and could not find any consistenency in the behaviour.

Perhaps having some of the ratio options that are in the rectangular and circular selection tool could be added to the context menu for brush?
Title: Re: Issues in last beta
Post by: Lucky Clan on February 11, 2019, 08:05:35 AM
Yes, Multitouch Mode is not enabled by default. You can still use old modes if you want.

Snapping - second tap should make Angle snapping to 15-30-45, but also 1:1 aspect ration in Rect/Ellipse select tool and when drawing Rect/Ellipse with Paint tool

Expand in bucket fill - i confirm it doesn't work for images > 4000, it will be fixed asap.

More... - as i also mis it i'm going to add that in Painting mode asap

Line freezing - i cannot reproduce this, could you give me more details and/or show that on video?
Title: Re: Issues in last beta
Post by: postdes on February 11, 2019, 08:47:39 AM
Thanks for the reply

Today snapping seems to work as it should. Not sure why it was buggy yesterday. Would it be possible to implement it in pencil only mode too? I get problems with palm rejection in the other mode, where I get accidental triggering of features.
Title: Re: Issues in last beta
Post by: Lucky Clan on February 12, 2019, 08:38:20 AM
It will work in Pencil Only mode in new beta.